0
Waiting for Customer
Base79 3 weeks ago in Portia • updated by Nestor Toledo Koplin (Support Engineer) 2 weeks ago 11

Hi there,


This tool is new to me, but I keep running into a problem right from the start.

The New Sample button doesn't show anywhere after I have created a new spider.

This way I can not select any data.

Waiting for Customer

Hey,


Could you please post a screenshot of where you get stuck?

Hi Nestor,


Thank you for your reply.


Please see the screenshot below. As you can see I have generated a spider but the Sample Button is not there, which makes it imposible to add anything.


You haven't created the spider yet, that is a preview of the page loaded. You need to click on New Spider first to create it and then you will be able to add the sample.

Have tried that over and over


Waiting for Customer

Have you tried clicking on the spider on the list on the left panel?

Yes several times. And also adding new spiders. I can't get it to work.

When I refresh the page it says no spiders are created.

I have this problem with both Chrome and FireFox.

I can't reproduce the issue, please try clearing cache and cookies and trying again preferably in a new project. Also if you're running any extensions in your browser, try disabling them or alternatively try in Chrome's Incognito mode.

It would also help if you could send us the log from your browsers console.

Hi Nestor, tried all the above just now but no results.

For a log on the browser console check below.


Waiting for Customer

Please try publishing the project as is above in the screenshot, then go back to the dashboard using the button at the top bar.

When you're in the Scrapinghub dashboard, on the left menu under Spiders click on Dashboard > open the spider > then click Open in Portia on the top-right side button.

Okay we are moving forward. This workaround with publishing seems to help me to show the button :)

Next problem: please see the tool-tip I get. When clicked the button says Edit Sample and the extraction field keeps showing the Extracting Data animation but nothing happens.


The tooltip seems weird, but if you get click the New sample and then you got Edit sample, that should be it, you should be able to add annotations. It won't extract anything on the right panel until you add annotations.