0
Started
robi9011235 3 weeks ago in Portia • updated 1 week ago 7

This article give me a bit of information but I still don't get what I need to do in order for it to work and the reason it's not working.

http://help.scrapinghub.com/portia/annotations-and-data-extraction

Answer

Answer
Started

Hey Robi, sorry to hear you have experienced problems using Portia.

When you said: "And I'm paying for this thing", that's strange, we offer Portia as a free service you shouldn't pay for it. Please let us know if some third party is charging you for use Portia.


About bugs and issues, unfortunately yes, we have been experiencing some, since our release of Portia v2 and we are trying to solve as soon as possible. Again, we offer our Portia as a free service and your contribution and constructive feedback are always welcome.


Please check: https://helpdesk.scrapinghub.com/support/solutions/articles/22000200446-troubleshooting-portia, to know more,


Best regards,


Pablo

Support team

Just wanted to mention, that when I select one item, it can succesfuly extrace the data, but when I use the tool for addind more items to existing annotation it falls apart and there is no extracted items at all.

Under review

Hello ,

Can you provide the link or name of the Portia project in which you have the issue.

Regards,

Thriveni Patil

Yes, the project name is: "stips"

There is one field Title which can extract only 1 item, and while the User has multiple Items. The multiple annotations works if the the elements has a particular structure; if it doesn't match the structure then it won't extract the data.


You can try to give the CSS selectors. By clicking on the option for the field, select the CSS and provide the required CSS selector.


But they match the same structure. They have the same HTML. And it still doesn't work. It's frustrating. And Portia is also completely buggy. And I'm paying for this thing.


I want to work with you to solve the problem, but such a fundamental thing in your product is so hard to get to work. So I'm selecting two items and then it recognizes all of them, but it's just doesn't extract any. It always says "Extracting data..." with a loader that goes forever... Sometimes it only extracts some of the data, but never all of it. A few days ago it extracted all of it but when I created a new annotation it completely failed extracting the previous data.

Answer
Started

Hey Robi, sorry to hear you have experienced problems using Portia.

When you said: "And I'm paying for this thing", that's strange, we offer Portia as a free service you shouldn't pay for it. Please let us know if some third party is charging you for use Portia.


About bugs and issues, unfortunately yes, we have been experiencing some, since our release of Portia v2 and we are trying to solve as soon as possible. Again, we offer our Portia as a free service and your contribution and constructive feedback are always welcome.


Please check: https://helpdesk.scrapinghub.com/support/solutions/articles/22000200446-troubleshooting-portia, to know more,


Best regards,


Pablo

Support team

Yeah, sorry about that, I felt a bit agitated from my experience. I'm paying for scraping hub additional units, not Portia.


It's really sad to see that you've sort of released yourself from responsibility when it comes to using larger projects in Portia (from the the doc). Portia is really easy to use, and really the best tool I've found for crawling with a GUI, but yes, it's heavily buggy.


Anyway, I'm looking forward to you to solve the bug.