Start a new topic
Answered

Wrong documentation about scrapinghub.yml

I orientated myself on this article to deploy a project. And it took a lot time for me to find a typo in scrapinghub.yml.

Wrong:

requirements:
  file: requirements.txt


Correct:

requirements_file: requirements.txt

 


Best Answer

I see, it explains why you weren't able to use the newer syntax. However, I don't have any obstacles with shub on Conda (installing pip, then installing any shub version via pip), is it something related with other dependencies you're using? Let us know if there's anything we could help with.


Thanx, after installing via pip I can deploy with newer syntax.

Answer

I see, it explains why you weren't able to use the newer syntax. However, I don't have any obstacles with shub on Conda (installing pip, then installing any shub version via pip), is it something related with other dependencies you're using? Let us know if there's anything we could help with.

scrapinghub.yml

 

projects:
  default: 364*** ;)
requirements_file: requirements.txt

shub version: 2.1.1 . unfortunately,  i can't upgrade to 2.8.1 with conda.

Both versions should work fine, with a small difference that the one with `requirements_file` is deprecated. 

So it doesn't seem to be a typo.


Could you please share your scrapinghub.yml config and shub tool version (output of `shub version`)?

Login to post a comment